<!DOCTYPE html>
<html lang="ru-RU">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<title>Как установить RPM в Ubuntu</title>
	<link rel="pingback" href="https://lumpics.ru/xmlrpc.php">
	
<!-- All In One SEO Pack 3.7.1[138,177] -->
<meta name="description"  content="Установка пакетных файлов формата RPM также возможна в операционной системе Ubuntu, однако для этого придется произвести процедуру конвертирования расширения." />

<script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://lumpics.ru/#organization","url":"https://lumpics.ru/","name":"Lumpics.ru","sameAs":[]},{"@type":"WebSite","@id":"https://lumpics.ru/#website","url":"https://lumpics.ru/","name":"Lumpics.ru","publisher":{"@id":"https://lumpics.ru/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://lumpics.ru/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#webpage","url":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/","inLanguage":"ru-RU","name":"Установка RPM-пакетов в Ubuntu","isPartOf":{"@id":"https://lumpics.ru/#website"},"breadcrumb":{"@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#breadcrumblist"},"description":"Установка пакетных файлов формата RPM также возможна в операционной системе Ubuntu, однако для этого придется произвести процедуру конвертирования расширения.","image":{"@type":"ImageObject","@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#primaryimage","url":"https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-RPM-v-Ubuntu-1.png","width":600,"height":600},"primaryImageOfPage":{"@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#primaryimage"},"datePublished":"2019-02-19T22:13:00+03:00","dateModified":"2020-07-11T12:42:28+03:00"},{"@type":"Article","@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#article","isPartOf":{"@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#webpage"},"author":{"@id":"https://lumpics.ru/author/patts/#author"},"headline":"Установка RPM-пакетов в Ubuntu","datePublished":"2019-02-19T22:13:00+03:00","dateModified":"2020-07-11T12:42:28+03:00","commentCount":0,"mainEntityOfPage":{"@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#webpage"},"publisher":{"@id":"https://lumpics.ru/#organization"},"articleSection":"Linux","image":{"@type":"ImageObject","@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#primaryimage","url":"https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-RPM-v-Ubuntu-1.png","width":600,"height":600}},{"@type":"Person","@id":"https://lumpics.ru/author/patts/#author","name":"Виктор Бухтеев","sameAs":[]},{"@type":"BreadcrumbList","@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/#breadcrumblist","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://lumpics.ru/","url":"https://lumpics.ru/","name":"Lumpics.ru"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/","url":"https://lumpics.ru/how-to-install-rpm-in-ubuntu/","name":"Установка RPM-пакетов в Ubuntu"}}]}]}</script>
<link rel="canonical" href="https://lumpics.ru/how-to-install-rpm-in-ubuntu/" />
<!-- All In One SEO Pack -->
<link rel='dns-prefetch' href='//s.w.org' />
<style id='quads-styles-inline-css'>
.quads-ad-label { font-size: 12px; text-align: center; color: #333;}
</style>
        <script src="https://lumpics.ru/wp-content/plugins/quick-adsense-reloaded/assets/js/ads.js"></script><script>document.cookie = 'quads_browser_width='+screen.width;</script>	
<link rel='stylesheet' href='/wp-content/themes/presentation-lite/style.css?2.1' type='text/css' media='all'/>
<link id="page_favicon" href="/favicon.png" rel="icon" type="image/png"/>

<script async src='//s.clickiocdn.com/t/219550/360_light.js'></script>

<meta name="theme-color" content="#f90">
<meta name="apple-mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-status-bar-style" content="#f90">
</head>
<body class="post-template-default single single-post postid-231715 single-format-standard group-blog">
<div id="topsite"></div>
<div class="header-area full">
<div class="main">
<header id="masthead" class="site-header inner">
<div class="header-elements">
<span class="site-title"><a href="/"><img src="/wp-content/uploads/2017/08/logo2018.png" style="width:30px" alt="Lumpics.ru" /> lumpics.ru</a></span>


<nav id="header-navigation" class="header-menu">
						
</nav>
</div>
</header>

<div class="main-menu-container inner">
<form role="search" method="get" id="fixsearch" action="/search/">
<input type="hidden" name="searchid" value="2292752">
<input type="search" placeholder="Поиск решения&hellip;" name="text" />
</form>
<div class="hamburger-menu">
    <input id="menu__toggle" type="checkbox" />
    <label class="menu__btn" for="menu__toggle">
      <span></span>
    </label>

<ul class="menu__box">

<li><a class="menu__item" href="/operating-systems/">Операционные системы</a><img src="/wp-content/themes/presentation-lite/down_menu.png" class="dropdown_image" alt="Раскрыть" />
				<ul class="submenu">
					<li><a href="/category/windows-10/">Windows 10</a></li>
					<li><a href="/category/android/">Android</a></li>
					<li><a href="/category/ios/">iOS</a></li>
					<li><a href="/category/linux/">Linux</a></li>
					<li><a href="/category/macos/">macOS</a></li>
				</ul></li>

<li><a class="menu__item" href="/software/">Программы</a><img src="/wp-content/themes/presentation-lite/down_menu.png" class="dropdown_image" alt="Раскрыть" />
<ul class="submenu">
<li><a href="/category/choose-program/">Подобрать программу</a></li>
</ul>
</li>

<li><a class="menu__item" href="/online-services/">Интернет-сервисы</a></li>
<li><a class="menu__item" href="/hardware/">Железо</a></li>

</ul>
</div>

</div>
</div>
</div>
<div class="main-content-area full">
<div class="main">
		
		
<div>
</div>	


			<div id="content" class="site-content inner">
	<div id="primary" class="content-area">
		<main id="main" class="site-main">

		
			
<article id="post-231715" class="post-231715 post type-post status-publish format-standard has-post-thumbnail hentry category-linux top">
	<header class="entry-header">
	
<h1 class="entry-title">Установка RPM-пакетов в Ubuntu</h1>
<!-- WP QUADS v. 2.0.17.1  Shortcode Ad -->
<div class="quads-location quads-ad8" id="quads-ad8" style="float:none;margin:0px;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Lumpics (728*90) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-8233281901599575"
     data-ad-slot="1882302433"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		<div class="entry-meta">
<div class="kama_breadcrumbs" itemscope itemtype="http://schema.org/BreadcrumbList"><span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://lumpics.ru" itemprop="item"><span itemprop="name">/</span></a><meta itemprop="position" content="1" /></span><span class="kb_sep"> » </span>
<span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a href="https://lumpics.ru/category/linux/" itemprop="item"><span itemprop="name">Linux</span></a><meta itemprop="position" content="2" /></span></div> | 
<span class="posted-on">
		<time class="entry-date published" datetime="2019-02-20T01:13:00+03:00">20.02.2019</time><time class="updated" datetime="2020-07-11T15:42:28+03:00">11.07.2020</time></span> | <span class="author vcard"><span class="fn">Виктор Бухтеев</span></span>

	
			</div>
	</header>
	<div class="entry-content">
<div class="imgtoc"><p><img loading="lazy" src="/wp-content/uploads/2019/02/Kak-ustanovit-RPM-v-Ubuntu-1.png" alt="Как установить RPM в Ubuntu" width="600" height="600" class="aligncenter size-full wp-image-231772" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-RPM-v-Ubuntu-1.png 600w, https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-RPM-v-Ubuntu-1-180x180.png 180w, https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-RPM-v-Ubuntu-1-270x270.png 270w" sizes="(max-width: 600px) 100vw, 600px" />

<!-- WP QUADS Content Ad Plugin v. 2.0.17.1 -->
<div class="mysalary" style="float:none;margin:0px;">
<div id="toc_container" class="no_bullets"><p class="toc_title">Содержание</p><ul class="toc_list"><li><a href="#_RPM-_Ubuntu">Устанавливаем RPM-пакеты в Ubuntu</a><ul><li><a href="#_1__Universe">Шаг 1: Добавление репозитория Universe</a></li><li><a href="#_2__Alien">Шаг 2: Установка утилиты Alien</a></li><li><a href="#_3__RPM">Шаг 3: Преобразование пакета RPM</a></li><li><a href="#_4__DEB">Шаг 4: Установка созданного DEB-пакета</a></li></ul></li><li><a href="#comments">Вопросы и ответы</a></li></ul></div>
</div>
</div>

</p>
<p>Установка программ в операционной системе Ubuntu производится путем распаковки содержимого из DEB-пакетов или с помощью скачивания необходимых файлов из официальных либо пользовательских хранилищ. Однако иногда программное обеспечение не поставляется в таком виде и хранится только в формате RPM. Далее мы бы хотели рассказать о методе инсталляции библиотек такого рода. 
<!-- WP QUADS Content Ad Plugin v. 2.0.17.1 -->
<div class="mysalary" style="float:none;margin:30px 0 30px 0;text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Lumpics (0 блок, 580*400) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:580px;height:400px"
     data-ad-client="ca-pub-8233281901599575"
     data-ad-slot="6744944977"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
</p>
<h2><span id="_RPM-_Ubuntu">Устанавливаем RPM-пакеты в Ubuntu</span></h2>
<p>RPM &#8212; формат пакетов различных приложений, заточенный под работу с дистрибутивами openSUSE, Fedora. По умолчанию в Ubuntu не предусмотрены средства, позволяющие произвести инсталляцию сохраненного в этом пакете приложения, поэтому придется выполнять дополнительные действия, чтобы вся процедура прошла успешно. Ниже мы разберем весь процесс пошагово, детально рассказывая обо всем поочередно.</p>
<p>Перед тем как переходить к попыткам установить RPM-пакет, внимательно ознакомьтесь с выбранным ПО &#8212; возможно, его удастся найти на пользовательском или официальном репозитории. Кроме этого, не поленитесь зайти на официальный сайт разработчиков. Обычно там находится несколько версий для скачивания, среди которых часто встречается и подходящий для Ubuntu формат DEB.</p>
<!-- WP QUADS Content Ad Plugin v. 2.0.17.1 -->
<div class="mysalary" style="float:none;margin:30px 0 30px 0;text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Lumpics (1 блок, 580*400) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:580px;height:400px"
     data-ad-client="ca-pub-8233281901599575"
     data-ad-slot="1013755247"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p><img loading="lazy" src="/wp-content/uploads/2019/02/Proverit-dostupnost-paketov-na-sajte-programmy-dlya-Ubuntu.png" alt="Проверить доступность пакетов на сайте программы для Ubuntu" width="950" height="622" class="aligncenter size-full wp-image-231756" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Proverit-dostupnost-paketov-na-sajte-programmy-dlya-Ubuntu.png 950w, https://lumpics.ru/wp-content/uploads/2019/02/Proverit-dostupnost-paketov-na-sajte-programmy-dlya-Ubuntu-412x270.png 412w" sizes="(max-width: 950px) 100vw, 950px" /></p>
<p>Если же все попытки отыскать другие библиотеки или хранилища оказались тщетными, ничего не остается делать, как пытаться инсталлировать RPM с помощью дополнительных средств. </p>
<h3><span id="_1__Universe">Шаг 1: Добавление репозитория Universe</span></h3>
<p>Порой для установки определенных утилит требуется расширение системных хранилищ. Одним из лучших репозиториев считается Universe, который активно поддерживается сообществом и периодически обновляется. Поэтому начать стоит именно с добавления новых библиотек в Ubuntu:</p>
<!-- WP QUADS Content Ad Plugin v. 2.0.17.1 -->
<div class="mysalary" style="float:none;margin:30px 0 30px 0;text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Lumpics (2 блок, 580*400) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:580px;height:400px"
     data-ad-client="ca-pub-8233281901599575"
     data-ad-slot="7763136047"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<ol>
<li>Откройте меню и запустите <em>&#171;Терминал&#187;</em>. Сделать это можно другим способом &#8212; просто нажмите на рабочем столе ПКМ и выберите нужный пункт.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Zapustit-terminal-cherez-menyu-v-Ubuntu.png" alt="Запустить терминал через меню в Ubuntu" width="950" height="697" class="aligncenter size-full wp-image-231762" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Zapustit-terminal-cherez-menyu-v-Ubuntu.png 950w, https://lumpics.ru/wp-content/uploads/2019/02/Zapustit-terminal-cherez-menyu-v-Ubuntu-368x270.png 368w" sizes="(max-width: 950px) 100vw, 950px" /></p>
<li>В открывшейся консоли следует ввести команду <code>sudo add-apt-repository universe</code> и нажать на клавишу <em>Enter</em>.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Dobavlenie-repozitoriya-Universe-v-Ubuntu.png" alt="Добавление репозитория Universe в Ubuntu" width="792" height="546" class="aligncenter size-full wp-image-231761" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Dobavlenie-repozitoriya-Universe-v-Ubuntu.png 792w, https://lumpics.ru/wp-content/uploads/2019/02/Dobavlenie-repozitoriya-Universe-v-Ubuntu-392x270.png 392w" sizes="(max-width: 792px) 100vw, 792px" /></p>
<li>Вам потребуется указать пароль учетной записи, поскольку действие выполняется через рут-доступ. При вводе символы отображаться не будут, вам надо только ввести ключ и нажать на <em>Enter</em>.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Vvod-parolya-dlya-dobavleniya-repozitoriya-v-Ubuntu.png" alt="Ввод пароля для добавления репозитория в Ubuntu" width="797" height="546" class="aligncenter size-full wp-image-231760" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Vvod-parolya-dlya-dobavleniya-repozitoriya-v-Ubuntu.png 797w, https://lumpics.ru/wp-content/uploads/2019/02/Vvod-parolya-dlya-dobavleniya-repozitoriya-v-Ubuntu-394x270.png 394w" sizes="(max-width: 797px) 100vw, 797px" /></p>
<li>Будут добавлены новые файлы или же появится уведомление о том, что компонент уже включен во все источники.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Zavershenie-dobavleniya-repozitoriya-v-Ubuntu.png" alt="Завершение добавления репозитория в Ubuntu" width="797" height="546" class="aligncenter size-full wp-image-231759" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Zavershenie-dobavleniya-repozitoriya-v-Ubuntu.png 797w, https://lumpics.ru/wp-content/uploads/2019/02/Zavershenie-dobavleniya-repozitoriya-v-Ubuntu-394x270.png 394w" sizes="(max-width: 797px) 100vw, 797px" /></p>
<!-- WP QUADS Content Ad Plugin v. 2.0.17.1 -->
<div class="mysalary" style="float:none;margin:30px 0 30px 0;text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Lumpics (3 блок, 580*400) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:580px;height:400px"
     data-ad-client="ca-pub-8233281901599575"
     data-ad-slot="8457480047"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<li>Если файлы были добавлены, обновите систему, прописав команду <code>sudo apt-get update</code>.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Obnovit-sistemnye-fajly-v-Ubuntu.png" alt="Обновить системные файлы в Ubuntu" width="797" height="546" class="aligncenter size-full wp-image-231758" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Obnovit-sistemnye-fajly-v-Ubuntu.png 797w, https://lumpics.ru/wp-content/uploads/2019/02/Obnovit-sistemnye-fajly-v-Ubuntu-394x270.png 394w" sizes="(max-width: 797px) 100vw, 797px" /></p>
<li>Дождитесь завершения обновления и переходите к следующему шагу.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Protsedura-obnovleniya-sistemnyh-fajlov-v-Ubuntu.png" alt="Процедура обновления системных файлов в Ubuntu" width="797" height="544" class="aligncenter size-full wp-image-231757" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Protsedura-obnovleniya-sistemnyh-fajlov-v-Ubuntu.png 797w, https://lumpics.ru/wp-content/uploads/2019/02/Protsedura-obnovleniya-sistemnyh-fajlov-v-Ubuntu-396x270.png 396w" sizes="(max-width: 797px) 100vw, 797px" /></p>
</ol>
<h3><span id="_2__Alien">Шаг 2: Установка утилиты Alien</span></h3>
<p>Для осуществления поставленной сегодня задачи мы будем задействовать простую утилиту под названием Alien. Она позволяет конвертировать пакеты формата RPM в DEB для дальнейшей их установки в Ubuntu. Процесс добавления утилиты не вызывает особых сложностей и выполняется одной командой.</p>
<ol>
<li>В консоли напечатайте <code>sudo apt-get install alien</code>.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Ustanovit-utilitu-Alien-v-Ubuntu.png" alt="Установить утилиту Alien в Ubuntu" width="800" height="549" class="aligncenter size-full wp-image-231764" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Ustanovit-utilitu-Alien-v-Ubuntu.png 800w, https://lumpics.ru/wp-content/uploads/2019/02/Ustanovit-utilitu-Alien-v-Ubuntu-393x270.png 393w" sizes="(max-width: 800px) 100vw, 800px" /></p>
<li>Подтвердите добавление, выбрав вариант <em>Д</em>.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Podtverdit-dobavlenie-fajlov-v-Ubuntu.png" alt="Подтвердить добавление файлов в Ub" width="799" height="550" class="aligncenter size-full wp-image-231763" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Podtverdit-dobavlenie-fajlov-v-Ubuntu.png 799w, https://lumpics.ru/wp-content/uploads/2019/02/Podtverdit-dobavlenie-fajlov-v-Ubuntu-392x270.png 392w" sizes="(max-width: 799px) 100vw, 799px" /></p>
<li>Ожидайте завершения скачивания и добавления библиотек.</li>
</ol>
<h3><span id="_3__RPM">Шаг 3: Преобразование пакета RPM</span></h3>
<p>Теперь переходим непосредственно к конвертированию. Для этого у вас на компьютере или подключенном носителе уже должен храниться необходимый софт. После завершения всех настроек останется произвести всего несколько действий:</p>
<ol>
<li>Откройте место хранения объекта через менеджер, щелкните на нем ПКМ и выберите пункт <em>&#171;Свойства&#187;</em>.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Perejti-k-svojstvam-RPM-paketa-v-Ubuntu.png" alt="Перейти к свойствам RPM-пакета в Ubuntu" width="953" height="648" class="aligncenter size-full wp-image-231770" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Perejti-k-svojstvam-RPM-paketa-v-Ubuntu.png 953w, https://lumpics.ru/wp-content/uploads/2019/02/Perejti-k-svojstvam-RPM-paketa-v-Ubuntu-397x270.png 397w" sizes="(max-width: 953px) 100vw, 953px" /></p>
<li>Здесь вы узнаете информацию о родительской папке. Запомните путь, он понадобится вам в дальнейшем.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Uznat-roditelskuyu-papku-paketa-v-Ubuntu.png" alt="Узнать родительскую папку пакета в Ubuntu" width="634" height="528" class="aligncenter size-full wp-image-231769" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Uznat-roditelskuyu-papku-paketa-v-Ubuntu.png 634w, https://lumpics.ru/wp-content/uploads/2019/02/Uznat-roditelskuyu-papku-paketa-v-Ubuntu-324x270.png 324w" sizes="(max-width: 634px) 100vw, 634px" /></p>
<li>Перейдите к <em>&#171;Терминалу&#187;</em> и введите команду <code>cd /home/user/folder</code>, где <em>user</em> &#8212; имя пользователя, а <em>folder</em> &#8212; название папки хранения файла. Таким образом, с помощью команды <em>cd</em> произойдет переход в директорию и все дальнейшие действия будут осуществляться в ней.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Perejti-v-neobhodimuyu-papku-cherez-terminal-v-Ubuntu.png" alt="Перейти в необходимую папку через терминал в Ubuntu" width="796" height="549" class="aligncenter size-full wp-image-231768" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Perejti-v-neobhodimuyu-papku-cherez-terminal-v-Ubuntu.png 796w, https://lumpics.ru/wp-content/uploads/2019/02/Perejti-v-neobhodimuyu-papku-cherez-terminal-v-Ubuntu-391x270.png 391w" sizes="(max-width: 796px) 100vw, 796px" /></p>
<li>Находясь в нужной папке, введите <code>sudo alien vivaldi.rpm</code>, где <em>vivaldi.rpm</em> &#8212; точное название нужного пакета. Учтите, что .rpm в конце дописывать обязательно.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Zapustit-protsess-konvertirovaniya-v-DEB-Ubuntu.png" alt="Запустить процесс конвертирования в DEB Ubuntu" width="797" height="544" class="aligncenter size-full wp-image-231767" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Zapustit-protsess-konvertirovaniya-v-DEB-Ubuntu.png 797w, https://lumpics.ru/wp-content/uploads/2019/02/Zapustit-protsess-konvertirovaniya-v-DEB-Ubuntu-396x270.png 396w" sizes="(max-width: 797px) 100vw, 797px" /></p>
<li>Снова введите пароль и дождитесь окончания конвертирования.</li>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Vvod-parolya-dlya-nachala-protsessa-konvertirovaniya-Ubuntu.png" alt="Ввод пароля для начала процесса кон" width="798" height="544" class="aligncenter size-full wp-image-231766" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Vvod-parolya-dlya-nachala-protsessa-konvertirovaniya-Ubuntu.png 798w, https://lumpics.ru/wp-content/uploads/2019/02/Vvod-parolya-dlya-nachala-protsessa-konvertirovaniya-Ubuntu-396x270.png 396w" sizes="(max-width: 798px) 100vw, 798px" /></p>
</ol>
<h3><span id="_4__DEB">Шаг 4: Установка созданного DEB-пакета</span></h3>
<p>После успешной процедуры преобразования вы можете перейти в ту папку, где изначально хранился пакет RPM, поскольку и конвертирование производилось в этой директории. Там уже будет храниться пакет с точно таким же названием, но формата DEB. Он доступен для установки стандартным встроенным средством или любым другим удобным методом. Развернутые инструкции по этой теме читайте в отдельном нашем материале далее.</p>
<p><img loading="lazy" src="/wp-content/uploads/2019/02/Nahozhdenie-gotovogo-paketa-DEB-v-Ubuntu.png" alt="Нахождение готового пакета DEB в Ubuntu" width="949" height="648" class="aligncenter size-full wp-image-231765" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Nahozhdenie-gotovogo-paketa-DEB-v-Ubuntu.png 949w, https://lumpics.ru/wp-content/uploads/2019/02/Nahozhdenie-gotovogo-paketa-DEB-v-Ubuntu-395x270.png 395w" sizes="(max-width: 949px) 100vw, 949px" /></p>
<p>Подробнее: <a href="/how-to-install-deb-packages-on-ubuntu/" rel="noopener noreferrer" target="_blank">Установка DEB-пакетов в Ubuntu</a></p>
<p>Как видите, пакетные файлы RPM все-таки инсталлируются в Ubuntu, однако следует отметить, что некоторые из них несовместимы с этой операционной системой вовсе, поэтому ошибка появится еще на стадии конвертирования. При возникновении такой ситуации рекомендуется отыскать RPM-пакет другой архитектуры или попытаться все-таки найти поддерживаемую версию, созданную специально для Ubuntu.
<!-- WP QUADS Content Ad Plugin v. 2.0.17.1 -->
<div class="mysalary" style="float:none;margin:30px 0 30px 0;text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Lumpics (последний блок, 580*400) -->
<ins class="adsbygoogle"
     style="display:inline-block;width:580px;height:400px"
     data-ad-client="ca-pub-8233281901599575"
     data-ad-slot="3265390733"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

			
<script>
 
function show(state){
 
                    document.getElementById('window').style.display = state;                                                                                                        
                    document.getElementById('wrap').style.display = state;          
            
            }
function show1(state){
 
                    document.getElementById('window1').style.display = state;           
                    document.getElementById('wrap1').style.display = state;             
            }
        </script>


<!-- Задний прозрачный фон-->
<div onclick="show('none')" id="wrap"></div>

<!-- Само окно-->
<div id="window">
<img src="/social/close.png" class="close" onclick="show('none')" alt="Закрыть" />
<strong>Мы рады, что смогли помочь Вам в решении проблемы.</strong><br/>	
<div class="popup">
Добавьте сайт Lumpics.ru в закладки и мы еще пригодимся вам. <br/>
Отблагодарите автора, поделитесь статьей в социальных сетях.<br/>
<script src="//yastatic.net/es5-shims/0.0.2/es5-shims.min.js"></script>
<script src="//yastatic.net/share2/share.js"></script>
<br/><div class="ya-share2" data-services="vkontakte,facebook,odnoklassniki,moimir,twitter,collections,telegram,whatsapp,viber,skype" data-counter=""></div>
</div>				
</div>


<!-- Задний прозрачный фон-->
<div onclick="show1('none')" id="wrap1"></div>

<!-- Само окно-->
<div id="window1">
<img src="/social/close.png" class="close" onclick="show1('none')" alt="Закрыть" />
<span class="widget-title">Опишите, что у вас не получилось.</span>
Наши специалисты постараются ответить максимально быстро.<br/>


</div>


<h4>Помогла ли вам эта статья?</h4>
<span style="text-align:center;display:block;"><a class="myButton" href="#helpgood" onclick="show('block')">ДА</a>  <a href="#comment" class="myButton">НЕТ</a></span>
</div>

<br/>
<h4>Поделиться статьей в социальных сетях:</h4>

<script src="//yastatic.net/es5-shims/0.0.2/es5-shims.min.js"></script>
<script src="//yastatic.net/share2/share.js"></script>
<div class="ya-share2" data-services="vkontakte,facebook,odnoklassniki,moimir,twitter,collections,telegram,whatsapp,viber,skype" data-counter=""></div>

</article><br/><br/>

<h4>Еще статьи по данной теме:</h4>
<div class='yarpp-related'>
<h3></h3>
<div class="yarpp-thumbnails-horizontal">
<a class='yarpp-thumbnail' href='https://lumpics.ru/how-to-install-deb-packages-on-ubuntu/' title='Установка DEB-пакетов в Ubuntu'>
<img width="180" height="180" src="https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-DEB-paket-na-Ubuntu-180x180.png" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="Как установить DEB-пакет на Ubuntu" loading="lazy" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-DEB-paket-na-Ubuntu-180x180.png 180w, https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-DEB-paket-na-Ubuntu-270x270.png 270w, https://lumpics.ru/wp-content/uploads/2019/02/Kak-ustanovit-DEB-paket-na-Ubuntu.png 600w" sizes="(max-width: 180px) 100vw, 180px" /><span>Установка DEB-пакетов в Ubuntu</span></a>
<a class='yarpp-thumbnail' href='https://lumpics.ru/installed-package-list-in-ubuntu/' title='Просмотр списка установленных пакетов в Ubuntu'>
<img width="180" height="180" src="https://lumpics.ru/wp-content/uploads/2019/02/Spisok-ustanovlennyh-paketov-v-Ubuntu-180x180.png" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="Список установленных пакетов в Ubuntu" loading="lazy" srcset="https://lumpics.ru/wp-content/uploads/2019/02/Spisok-ustanovlennyh-paketov-v-Ubuntu-180x180.png 180w, https://lumpics.ru/wp-content/uploads/2019/02/Spisok-ustanovlennyh-paketov-v-Ubuntu-270x270.png 270w, https://lumpics.ru/wp-content/uploads/2019/02/Spisok-ustanovlennyh-paketov-v-Ubuntu.png 600w" sizes="(max-width: 180px) 100vw, 180px" /><span>Просмотр списка установленных пакетов в Ubuntu</span></a>
<a class='yarpp-thumbnail' href='https://lumpics.ru/installation-deb-package-in-debian/' title='Установка DEB-пакетов в Debian'>
<img width="180" height="180" src="https://lumpics.ru/wp-content/uploads/2019/11/ustanovka-deb-paketov-v-debian-180x180.png" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="Установка DEB-пакетов в Debian" loading="lazy" srcset="https://lumpics.ru/wp-content/uploads/2019/11/ustanovka-deb-paketov-v-debian-180x180.png 180w, https://lumpics.ru/wp-content/uploads/2019/11/ustanovka-deb-paketov-v-debian-270x270.png 270w, https://lumpics.ru/wp-content/uploads/2019/11/ustanovka-deb-paketov-v-debian.png 500w" sizes="(max-width: 180px) 100vw, 180px" /><span>Установка DEB-пакетов в Debian</span></a>
<a class='yarpp-thumbnail' href='https://lumpics.ru/install-packages-in-centos/' title='Установка пакетов в CentOS'>
<img width="180" height="180" src="https://lumpics.ru/wp-content/uploads/2019/12/ustanovka-paketov-v-centos-180x180.png" class="attachment-yarpp-thumbnail size-yarpp-thumbnail wp-post-image" alt="Установка пакетов в CentOS" loading="lazy" srcset="https://lumpics.ru/wp-content/uploads/2019/12/ustanovka-paketov-v-centos-180x180.png 180w, https://lumpics.ru/wp-content/uploads/2019/12/ustanovka-paketov-v-centos-270x270.png 270w, https://lumpics.ru/wp-content/uploads/2019/12/ustanovka-paketov-v-centos.png 500w" sizes="(max-width: 180px) 100vw, 180px" /><span>Установка пакетов в CentOS</span></a>
</div>
</div>
<br/>
				
	
			

		
		</main>
		
<div id="comments" class="comments-area">

	
	
	
		<div id="respond" class="comment-respond">
		<p id="reply-title" class="comment-reply-title">Задайте вопрос или оставьте свое мнение <small><a rel="nofollow" id="cancel-comment-reply-link" href="/how-to-install-rpm-in-ubuntu/#respond" style="display:none;">Отменить комментарий</a></small></p><form action="https://lumpics.ru/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><strong>Примечание:</strong> если отправленный комментарий не появился на странице, значит он ушел на проверку и скоро будет опубликован. Пожалуйста, не дублируйте вопрос. Мы ответим Вам в ближайшее время. <p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author comment-form-field"><input id="author" name="author" type="text" placeholder="Ваше имя (необязательно)" /></p>
<p class="comment-form-subscriptions"><label for="subscribe-reloaded"> Сообщить мне об ответе на E-mail.<input style="float:left;margin: 8px 5px 0 0;" name="subscribe-reloaded" id="subscribe-reloaded" value="yes" type="checkbox" onclick="if(this.checked){this.nextSibling.style.display=''}else {this.nextSibling.style.display='none';  this.nextSibling.value='';}"><input id="email" name="email" type="text" placeholder="Укажите Email, на который Вам отправить ответ" style="display: none;margin: 10px 0 0"></label></p><div style="display:none;"><select name='subscribe-reloaded' id='subscribe-reloaded'>
								<option value='none' >Не подписываться</option>
								<option value='yes' >Все</option>
								<option value='replies' selected='selected'>Ответы на мои комментарии</option>
							</select></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Опубликовать комментарий" /> <input type='hidden' name='comment_post_ID' value='231715' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="e6b34e6cfe" /></p><div id="comment-image-reloaded-wrapper"><p id="comment-image-reloaded-error"></p><label for='comment_image_reloaded_231715'>Прикрепить скриншот (GIF, PNG, JPG, JPEG): до 3 штук</label><p class='comment-image-reloaded'><input type='file' name=comment_image_reloaded_231715[] id='comment_image_reloaded' multiple='multiple' /></p></div><!-- #comment-image-wrapper --><input type="hidden" id="ak_js" name="ak_js" value="80"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	</div>	</div>




	<div id="secondary" class="widget-area" role="complementary">
<aside id="toc-widget-5" class="widget toc_widget"><span class="widget-title">Содержание</span><ul class="toc_widget_list no_bullets"><li><a href="#_RPM-_Ubuntu">Устанавливаем RPM-пакеты в Ubuntu</a><ul><li><a href="#_1__Universe">Шаг 1: Добавление репозитория Universe</a></li><li><a href="#_2__Alien">Шаг 2: Установка утилиты Alien</a></li><li><a href="#_3__RPM">Шаг 3: Преобразование пакета RPM</a></li><li><a href="#_4__DEB">Шаг 4: Установка созданного DEB-пакета</a></li></ul></li><li><a href="#comments">Вопросы и ответы</a></li></ul></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<!-- WP QUADS v. 2.0.17.1  Shortcode Ad -->
<div class="quads-location quads-ad9" id="quads-ad9" style="float:none;margin:0px;">
<script async src='//s.clickiocdn.com/t/219550/360_light.js'></script>
<script class='__lxGc__'>
((__lxGc__=window.__lxGc__||{'s':{},'b':0})['s']['_219550']=__lxGc__['s']['_219550']||{'b':{}})['b']['_668764']={'i':__lxGc__.b++};
</script></div>
</div></aside></div>




			</div>
		</div>
	</div>

	<div class="footer-area full">
		<div class="main">
			<footer id="colophon" class="site-footer inner">
				<span class="site-info">
&copy; Lumpics.ru, 2016-2020. 11384 решений ваших проблем<br/>
<a href="/">Главная страница</a> | <a href="/about/">О нас</a> | <a href="/sitemap.xml">Карта сайта</a> | <a href="/privacy-policy-and-terms-use/">Политика конфиденциальности и условия</a><br/>
Копирование материалов сайта разрешено лишь при указании активной, прямой ссылки на источник.
				</span>
<br/>Запросов 84, за 0,066 секунды. 15.24 MB			</footer>
		</div>
	</div>
<script>
( function() {
	var container, button, menu;

	container = document.getElementById( 'site-navigation' );
	if ( ! container )
		return;

	button = container.getElementsByTagName( 'span' )[0];
	if ( 'undefined' === typeof button )
		return;

	menu = container.getElementsByTagName( 'ul' )[0];

	// Hide menu toggle button if menu is empty and return early.
	if ( 'undefined' === typeof menu ) {
		button.style.display = 'none';
		return;
	}

	if ( -1 === menu.className.indexOf( 'nav-menu' ) )
		menu.className += ' nav-menu';

	button.onclick = function() {
		if ( -1 !== container.className.indexOf( 'toggled' ) )
			container.className = container.className.replace( ' toggled', '' );
		else
			container.className += ' toggled';
	};
} )();</script>
<script src='https://lumpics.ru/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script id='ec-stars-script-js-extra'>
var ec_ajax_data = {"ajax_url":"https:\/\/lumpics.ru\/wp-admin\/admin-ajax.php","codes":{"SUCCESS":1,"PREVIOUSLY_VOTED":0,"REQUEST_ERROR":2,"UNKNOWN":-1},"messages":{"success":"\u0412\u044b \u0443\u0436\u0435 \u043f\u0440\u043e\u0433\u043e\u043b\u043e\u0441\u043e\u0432\u0430\u043b\u0438","previously_voted":"\u0412\u044b \u0443\u0436\u0435 \u0433\u043e\u043b\u043e\u0441\u043e\u0432\u0430\u043b\u0438","request_error":"\u041d\u0435\u0432\u0435\u0440\u043d\u044b\u0439 \u0437\u0430\u043f\u0440\u043e\u0441, \u043f\u043e\u043f\u0440\u043e\u0431\u0443\u0439\u0442\u0435 \u0435\u0449\u0451 \u0440\u0430\u0437","unknown":"\u041d\u0435\u0438\u0437\u0432\u0435\u0441\u0442\u043d\u0430\u044f \u043e\u0448\u0438\u0431\u043a\u0430 \u043f\u0440\u043e\u0438\u0437\u043e\u0448\u043b\u0430, \u043f\u043e\u043f\u0440\u043e\u0431\u0443\u0439\u0442\u0435 \u0435\u0449\u0435 \u0440\u0430\u0437 \u0433\u043e\u043b\u043e\u0441\u043e\u0432\u0430\u0442\u044c"}};
</script>
<script src='https://lumpics.ru/wp-content/plugins/ec-stars-rating/js/ec-stars-rating.js?ver=e9b542397246d46ff0bc3d753c12918f' id='ec-stars-script-js'></script>
<script id='comment-images-reloaded-js-extra'>
var cm_imgs = {"fileTypeError":"\u0412\u043d\u0438\u043c\u0430\u043d\u0438\u0435! \u0412\u044b \u043f\u044b\u0442\u0430\u0435\u0442\u0435\u0441\u044c \u0437\u0430\u0433\u0440\u0443\u0437\u0438\u0442\u044c \u043d\u0435\u0432\u0435\u0440\u043d\u043e\u0435 \u0438\u0437\u043e\u0431\u0440\u0430\u0436\u0435\u043d\u0438\u0435, \u043f\u043e\u044d\u0442\u043e\u043c\u0443 \u043e\u043d\u043e \u043d\u0435 \u0431\u0443\u0434\u0435\u0442 \u043f\u0440\u0438\u043a\u0440\u0435\u043f\u043b\u0435\u043d\u043e \u043a \u0432\u0430\u0448\u0435\u043c\u0443 \u043a\u043e\u043c\u043c\u0435\u043d\u0442\u0430\u0440\u0438\u044e.","fileSizeError":"\u0412\u043d\u0438\u043c\u0430\u043d\u0438\u0435! \u0412\u044b \u043f\u044b\u0442\u0430\u0435\u0442\u0435\u0441\u044c \u0437\u0430\u0433\u0440\u0443\u0437\u0438\u0442\u044c \u0441\u043b\u0438\u0448\u043a\u043e\u043c \u0431\u043e\u043b\u044c\u0448\u043e\u0439 \u0444\u0430\u0439\u043b. \u041f\u0440\u0438 \u0441\u043e\u0445\u0440\u0430\u043d\u0435\u043d\u0438\u0438 \u043a\u043e\u043c\u043c\u0435\u043d\u0442\u0430\u0440\u0438\u044f, \u0444\u0430\u0439\u043b \u043d\u0435 \u0431\u0443\u0434\u0435\u0442 \u043f\u0440\u0438\u043a\u0440\u0435\u043f\u043b\u0435\u043d! \u041c\u0430\u043a\u0441\u0438\u043c\u0430\u043b\u044c\u043d\u044b\u0439 \u0440\u0430\u0437\u043c\u0435\u0440 \u0444\u0430\u0439\u043b\u0430:","limitFileSize":"10485760","fileCountError":"<strong>\u0412\u043d\u0438\u043c\u0430\u043d\u0438\u0435!<\/strong> \u0412\u044b \u043f\u044b\u0442\u0430\u0435\u0442\u0435\u0441\u044c \u0437\u0430\u0433\u0440\u0443\u0437\u0438\u0442\u044c \u0441\u043b\u0438\u0448\u043a\u043e\u043c \u043c\u043d\u043e\u0433\u043e \u0444\u0430\u0439\u043b\u043e\u0432. \u041f\u0440\u0438 \u043e\u0442\u043f\u0440\u0430\u0432\u043a\u0435 \u043a\u043e\u043c\u0435\u043d\u0442\u0430\u0440\u0438\u044f, \u0444\u0430\u0439\u043b\u044b \u043d\u0435 \u0431\u0443\u0434\u0443\u0442 \u0437\u0430\u0433\u0440\u0443\u0436\u0435\u043d\u044b <br \/>\u041c\u0430\u043a\u0441\u0438\u043c\u0430\u043b\u044c\u043d\u043e\u0435 \u043a\u043e\u043b\u0438\u0447\u0435\u0441\u0442\u0432\u043e \u0438\u0437\u043e\u0431\u0440\u0430\u0436\u0435\u043d\u0438\u0439: ","limitFileCount":"3"};
</script>
<script src='https://lumpics.ru/wp-content/plugins/comment-images-reloaded/js/cir_andzoom.min.js?ver=e9b542397246d46ff0bc3d753c12918f' id='comment-images-reloaded-js'></script>
<script id='toc-front-js-extra'>
var tocplus = {"smooth_scroll":"1"};
</script>
<script src='https://lumpics.ru/wp-content/plugins/table-of-contents-plus/front.min.js?ver=2002' id='toc-front-js'></script>
<script src='https://lumpics.ru/wp-includes/js/comment-reply.min.js?ver=e9b542397246d46ff0bc3d753c12918f' id='comment-reply-js'></script>
<script id='q2w3_fixed_widget-js-extra'>
var q2w3_sidebar_options = [{"sidebar":"sidebar-1","margin_top":60,"margin_bottom":0,"stop_id":"","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["toc-widget-5","custom_html-2"]}];
</script>
<script src='https://lumpics.ru/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.1.9' id='q2w3_fixed_widget-js'></script>
<script async="async" src='https://lumpics.ru/wp-content/plugins/akismet/_inc/form.js?ver=4.1.8' id='akismet-form-js'></script>
<script>
   if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' && quadsOptions.quadsChoice == 'ad_blocker_message'){

  var addEvent1 = function (obj, type, fn) {
      if (obj.addEventListener)
          obj.addEventListener(type, fn, false);
      else if (obj.attachEvent)
          obj.attachEvent('on' + type, function () {
              return fn.call(obj, window.event);
          });
  };
   addEvent1(window, 'load', function () {
      if (typeof wpquads_adblocker_check_2 === "undefined" || wpquads_adblocker_check_2 === false) {
          highlight_adblocked_ads();
      }
  });

   function highlight_adblocked_ads() {
      try {
          var ad_wrappers = document.querySelectorAll('div[id^="quads-ad"]')
      } catch (e) {
          return;
      }

      for (i = 0; i < ad_wrappers.length; i++) {
          ad_wrappers[i].className += ' quads-highlight-adblocked';
          ad_wrappers[i].className = ad_wrappers[i].className.replace('quads-location', '');
          ad_wrappers[i].setAttribute('style', 'display:block !important');
      }
  }
 }

(function() {
//Adblocker Notice Script Starts Here
var curr_url = window.location.href;
var red_ulr = localStorage.getItem('curr');
var modal = document.getElementById("quads-myModal");
var quadsAllowedCookie =  quadsgetCookie('quadsAllowedCookie');

if(typeof quadsOptions !== 'undefined' && typeof wpquads_adblocker_check_2 
  === 'undefined' ){

  if(quadsAllowedCookie!=quadsOptions.allow_cookies){
    quadssetCookie('quadsCookie', '', -1, '/');
    quadssetCookie('quadsAllowedCookie', quadsOptions.allow_cookies, 1, '/');
  }

  if(quadsOptions.allow_cookies == 2){
    if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
        modal.style.display = "block";
        quadssetCookie('quadsCookie', '', -1, '/');
    }
    
    if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        if(red_ulr==null || curr_url!=quadsOptions.page_redirect){
        window.location = quadsOptions.page_redirect;
        localStorage.setItem('curr',quadsOptions.page_redirect);
      }
    }
  }else{
    var adsCookie = quadsgetCookie('quadsCookie');
    if(adsCookie==false) {
      if( quadsOptions.quadsChoice == 'bar' || quadsOptions.quadsChoice == 'popup'){
          modal.style.display = "block";
      }
      if(quadsOptions.quadsChoice == 'page_redirect' && quadsOptions.page_redirect !="undefined"){
        window.location = quadsOptions.page_redirect;
        quadssetCookie('quadsCookie', true, 1, '/');
      }
    }else{
      modal.style.display = "none";
    }
  }
}

function quadsgetCookie(cname){
    var name = cname + '=';
    var ca = document.cookie.split(';');
    for (var i = 0; i < ca.length; i++) {
        var c = ca[i].trim();
        if (c.indexOf(name) === 0) {
            return c.substring(name.length, c.length);
        }
    }
    return false;
}
function quadssetCookie(cname, cvalue, exdays, path){
  var d = new Date();
  d.setTime(d.getTime() + (exdays*24*60*60*1000));
  var expires = "expires="+ d.toUTCString();
  document.cookie = cname + "=" + cvalue + ";" + expires + ";path=/";
}

var span = document.getElementsByClassName("quads-cls-notice")[0];
if(span){
  span.onclick = function() {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}

window.onclick = function(event) {
  if (event.target == modal) {
    modal.style.display = "none";
    document.cookie = "quads_prompt_close="+new Date();
    quadssetCookie('quadsCookie', 'true', 1, '/');
  }
}
})();
//Adblocker Notice Script Ends Here
</script>

<link rel='stylesheet' id='wp-block-library-css'  href='https://lumpics.ru/wp-includes/css/dist/block-library/style.min.css?ver=e9b542397246d46ff0bc3d753c12918f' media='all' />
<link rel='stylesheet' id='quads-style-css-css'  href='https://lumpics.ru/wp-content/plugins/quick-adsense-reloaded/includes/gutenberg/dist/blocks.style.build.css?ver=2.0.17.1' media='all' />
<link rel='stylesheet' id='magnific-css'  href='https://lumpics.ru/wp-content/plugins/comment-images-reloaded/js/magnific.css?ver=e9b542397246d46ff0bc3d753c12918f' media='all' />
<!--LiveInternet counter--><script><!--
new Image().src = "//counter.yadro.ru/hit?r"+
escape(document.referrer)+((typeof(screen)=="undefined")?"":
";s"+screen.width+"*"+screen.height+"*"+(screen.colorDepth?
screen.colorDepth:screen.pixelDepth))+";u"+escape(document.URL)+
";"+Math.random();//--></script><!--/LiveInternet-->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-86545937-1', 'auto');
  ga('send', 'pageview');

</script>
<script src='/wp-content/themes/presentation-lite/script.js?1.0'></script>
<script> 
(function(){function b(){var a=document.getElementById("gotop");a||(a=document.createElement("a"),a.id="gotop",a.className="scrollTop",a.href="#",a.style.display="none",a.style.position="fixed",a.style.zIndex="9999",a.onclick=function(a){a.preventDefault();window.top.goTop()},document.body.appendChild(a));300<(document.body.scrollTop||document.documentElement.scrollTop)?(a.style.display="block",l(a,"show",30,!1)):l(a,"hide",30,function(){a.style.display="none"});return!1}function l(a,e,f,c){function k(){g<
h?(d+=5,d<h?window.top.timeout=setTimeout(k,f):c&&c()):(d-=5,d>h?window.top.timeout=setTimeout(k,f):c&&c());var e=a,b=d;e.style.opacity=b/100;e.style.filter="alpha(opacity="+b+")"}var g=Math.round(100*a.style.opacity),d=g,h="show"==e?100:0;clearTimeout(window.top.timeout);window.top.timeout=setTimeout(k,30)}window.addEventListener?(window.addEventListener("scroll",b,!1),window.addEventListener("load",b,!1)):window.attachEvent&&(window.attachEvent("onscroll",b),window.attachEvent("onload",b));window.top.goTop=
function(a,e){a=a||0.1;e=e||12;var f=0,c=0,b=0,g=0,d=0,h=0;document.documentElement&&(f=document.documentElement.scrollLeft||0,c=document.documentElement.scrollTop||0);document.body&&(b=document.body.scrollLeft||0,g=document.body.scrollTop||0);d=window.scrollX||0;h=window.scrollY||0;f=Math.max(d,Math.max(b,f));c=Math.max(h,Math.max(g,c));g=1+a;window.scrollTo(Math.floor(f/g),Math.floor(c/g));(0<f||0<c)&&window.setTimeout("top.goTop("+a+", "+e+")",e);return!1}})();
</script>

<!-- Yandex.Metrika counter -->
<script>
   (function(m,e,t,r,i,k,a){m[i]=m[i]||function(){(m[i].a=m[i].a||[]).push(arguments)};
   m[i].l=1*new Date();k=e.createElement(t),a=e.getElementsByTagName(t)[0],k.async=1,k.src=r,a.parentNode.insertBefore(k,a)})
   (window, document, "script", "https://mc.yandex.ru/metrika/tag.js", "ym");

   ym(36609485, "init", {
        clickmap:true,
        trackLinks:true,
        accurateTrackBounce:true,
        webvisor:true
   });
</script>
<noscript><div><img src="https://mc.yandex.ru/watch/36609485" style="position:absolute; left:-9999px;" alt="" /></div></noscript>
<!-- /Yandex.Metrika counter -->
</body>
</html>