Примеры функции СЧЁТЕСЛИ с несколькими условиями в Microsoft Excel

Функция «СЧЁТЕСЛИ», часто использующаяся в Excel, относится к критериям. Если у вас еще нет базовых понятий о функциях, относящихся к этой группе, ознакомьтесь с общим их описанием в инструкции по ссылке ниже.

Читайте также: Использование критериев в Microsoft Excel

Описание синтаксиса функции

Начать следует с описания синтаксиса самой функции «СЧЁТЕСЛИ», поскольку при работе с несколькими условиями понадобится создавать большую формулу, учитывая все особенности.

  1. Для простоты понимания структуры предлагаем объявить в поле =СЧЁТЕСЛИ() и сразу перейти к меню «Аргументы функции».
  2. Объявление функции СЧЁТЕСЛИ в Excel для разбора ее синтаксиса

  3. В нем вы увидите строки «Диапазон» и «Критерий». Нажмите по первой для ее активации.
  4. Строка добавления диапазона для функции СЧЁТЕСЛИ в Excel в окне Аргументы функции

  5. В качестве диапазона указывается выборка данных, которая и должна попадать в функцию. Проще всего ее указать путем выделения ячеек, не закрывая при этом текущее окно.
  6. Пример добавления диапазона для функции СЧЁТЕСЛИ в Excel через окно Аргументы функции

  7. Далее остается только добавить критерий во второе поле — то есть происходит указание самого условия. Не забывайте, что числа вписываются просто так, а текст берется в двойные кавычки.
  8. Пример критерия при разборе синтаксиса функции СЧЁТЕСЛИ в Excel

Внизу под полями виден результат, что уже свидетельствует о правильном составлении функции. Сейчас добавить еще одно условие нельзя, поэтому формулу придется расширять, о чем и пойдет речь в следующих двух вариантах.

Вариант 1: Счет текстовых условий

Разберем ситуацию, когда есть два столбца с определенными значениями, которыми в нашем случае выступают месяцы. Нужно сделать выборку из них, чтобы в результате показывало значение того, сколько ячеек соответствуют заданному условию. Объединяются два условия при помощи одной простой формулы.

  1. Создайте первую часть функции «СЧЁТЕСЛИ», указав в качестве диапазона первый столбец. Сама функция имеет стандартный вид: =СЧЁТЕСЛИ(A2:A25;"Критерий").
  2. Создание первой части функции СЧЁТЕСЛИ в Excel для примера нескольких текстовых условий

  3. Добавьте знак сложения («+»), который и послужит соединительным для двух условий.
  4. Добавление знака плюса при создании функции СЧЁТЕСЛИ в Excel для нескольких текстовых условий

  5. Сразу же после него впишите вторую часть — =СЧЁТЕСЛИ(B2:B25;"Критерий") — и нажмите клавишу ввода.
  6. Формирование полной формулы с функцией СЧЁТЕСЛИ в Excel для расчета нескольких текстовых условий

  7. Если нужно, дописывайте любое количество плюсов, добавляя диапазоны и критерии точно в таком же ключе.
  8. Добавление знака плюса для прибавления других условий при использовании функции СЧЁТЕСЛИ в Excel

Проверьте результат, который отобразится в заданной клетке. Если вдруг возникла ошибка, удостоверьтесь в том, что вы правильно соблюли синтаксис функции, а ячейки в диапазоне имеют соответствующий формат.

Вариант 2: Счет числовых условий

С числовыми условиями дела обстоят точно так же, но на этот раз давайте рассмотрим более детальный пример ручного составления функции, учитывая каждую деталь.

  1. После объявления «СЧЁТЕСЛИ» в круглых скобках задайте диапазон чисел «A1:A25», где вместо указанных ячеек подставьте необходимые.
  2. Создание первой части функции СЧЁТЕСЛИ в Excel для нескольких числовых критериев

  3. Сразу за диапазоном без пробела добавьте знак «;», который объявляет его закрытие.
  4. Закрытие диапазона числовых данных при создании функции СЧЁТЕСЛИ в Excel

  5. После него просто напишите число, которое хотите посчитать.
  6. Добавление числового критерия при создании функции СЧЁТЕСЛИ в Excel для нескольких условий

  7. Поставьте знак «+» и допишите вторую часть формулы точно так же.
  8. Создание второй части функции СЧЁТЕСЛИ в Excel для нескольких числовых условий

  9. Как только вы нажмете клавишу Enter, в ячейке отобразится число, которое и будет результатом математического действия с двумя указанными критериями.
  10. Успешное создание функции СЧЁТЕСЛИ в Excel для нескольких числовых условий

Закрыть Мы рады, что смогли помочь Вам в решении проблемы.
Закрыть Опишите, что у вас не получилось. Наши специалисты постараются ответить максимально быстро.

Помогла ли вам эта статья?

ДА НЕТ

Поделиться статьей в социальных сетях:



Еще статьи по данной теме:


Задайте вопрос или оставьте свое мнение

Примечание: если отправленный комментарий не появился на странице, значит он ушел на проверку и скоро будет опубликован. Пожалуйста, не дублируйте вопрос. Мы ответим Вам в ближайшее время.