Главная » Excel » Вы здесь

Создание кроссворда в программе Microsoft Excel

Кроссворд в Microsoft Excel

Многие люди любят разгадывать кроссворды, есть так же лица, которым нравится их составлять. Иногда, составить кроссворд требуется не просто ради развлечения, а, например, чтобы проверить знания учащихся нестандартным способом. Но, мало кто догадывается, что отличным инструментом для создания кроссвордов является программа Microsoft Excel. И, действительно, ячейки на листе данного приложения, как будто специально предназначены для того, чтобы вписывать туда буквы отгадываемых слов. Давайте выясним, как быстро составить кроссворд в программе Microsoft Excel.

Создание кроссворда

Прежде всего, нужно найти готовый кроссворд, с которого вы будете делать копию в программе Excel, или же продумать структуру кроссворда, если вы будете придумывать его полностью сами.

Для кроссворда нужны квадратные ячейки, а не прямоугольные, как по умолчанию в Microsoft Excel. Нам нужно изменить их форму. Для этого, на клавиатуре нажимаем комбинацию клавиш Ctrl+A. Этим мы выделяем весь лист. Затем, кликаем правой кнопкой мыши, чем вызываем контекстное меню. В нём кликаем по пункту «Высота строки».

Высота строки в Microsoft Excel

Открывается небольшое окошко, в котором нужно задать высоту строки. Устанавливаем значение 18. Жмем на кнопку «OK».

Установка высоты строки в Microsoft Excel

Чтобы изменить ширину, кликаем по панели с наименованием столбцов, и в появившемся меню выбираем пункт «Ширина столбца…».

Переход к изменению ширины столбца в Microsoft Excel

Как и в предыдущем случае, появляется окошко, в которое нужно внести данные. На этот раз это будет число 3. Жмем на кнопку «OK».

Ширина столбца в Microsoft Excel

Далее, следует подсчитать число клеточек для букв в кроссворде в горизонтальном и вертикальном направлении. Выделяем соответствующее количество ячеек на листе Excel. Находясь во вкладке «Главная», кликаем по кнопке «Граница», которая расположена на ленте в блоке инструментов «Шрифт». В появившемся меню, выбираем пункт «Все границы».

Установка границ в Microsoft Excel

Как видим, границы, очерчивающие наш кроссворд, установлены.

Установлены границы в Microsoft Excel

Теперь, следует удалить эти границы в некоторых местах, чтобы кроссворд принял нужный для нас вид. Это можно сделать при помощи такого инструмента, как «Очистить», значок запуска которого имеет форму ластика, и находится в блоке инструментов «Редактирование» всё той же вкладки «Главная». Выделяем границы ячеек, которые хотим стереть и кликаем на данную кнопку.

Кнопка очистить в Microsoft Excel

Таким образом, постепенно прорисовываем наш кроссворд, поочередно удаляя границы, и получаем готовый результат.

Кроссворд нарисован в Microsoft Excel

Для наглядности, в нашем случае, можно выделить горизонтальную строку кроссворда другим цветом, например желтым, воспользовавшись для этого кнопкой «Цвет заливки» на ленте.

Заливка желтым цветом в Microsoft Excel

Далее, проставляем номера вопросов на кроссворде. Лучше всего, это делать не слишком большим шрифтом. В нашем случае, использован шрифт 8.

Номера кроссворда в Microsoft Excel

Для того, чтобы разместить сами вопросы, можно кликнуть любую область ячеек в стороне от кроссворда, и нажать на кнопку «Объединить ячейки», которая находится на ленте всё на той же вкладке в блоке инструментов «Выравнивание».

Объединение ячеек в Microsoft Excel

Далее, в большой объединенной ячейке можно пропечатать, или скопировать туда вопросы кроссворда.

Вопросы кроссворда в Microsoft Excel

Собственно, сам кроссворд на этом готов. Его можно распечатывать, или разгадывать прямо в Экселе.

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Таблица с результатами в Microsoft Excel

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

Вызов мастера функций в Microsoft Excel

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Мастер функций в Microsoft Excel

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Переход к выбору ячейки в Microsoft Excel

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Выбор диапазона ячеек в Microsoft Excel

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Данные введены в Microsoft Excel

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Функция СТРОЧН в Microsoft Excel

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Функция ЕСЛИ в Microsoft Excel

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Автосумма в Microsoft Excel

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Ответ на кроссворд в Microsoft Excel

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

Мы рады, что смогли помочь Вам в решении проблемы.
Попробуйте найти другие ответы на сайте



...или задайте вопрос в комментариях, где Вам обязательно ответят в кратчайшие сроки.

Опрос: помогла ли вам эта статья?

Да Нет

Еще статьи по этой теме:

Поделиться статьей в социальных сетях

Оставьте свое мнение